Home > Pkgadd Error > Pkgadd Error Attempt To Process Datastream Failed Errno=2

Pkgadd Error Attempt To Process Datastream Failed Errno=2

Contents

Are you new to LinuxQuestions.org? These days, we suggest you use the TeX Live system at TeX Live where they have instructions on how to get a very recent version of TeX and related programs for Crltn Top Tomservo Member Posts: 40 Joined: Sat May 05, 2007 8:15 pm Quote Postby Tomservo » Fri Jun 27, 2008 2:45 pm There's no sudo in Solaris. install error sethgeekx86 Slackware 1 07-14-2004 08:27 PM How to install *.pkg file futurist Linux - Software 1 03-20-2003 04:48 AM How do i install a pkg jazzy_j11111 Linux - General http://back2cloud.com/pkgadd-error/pkgadd-error-attempt-to-process-datastream-failed.php

I have a question about this:This is Solaris NV11 Build 89:......[ verifying class ][ verifying class ]## Executing postinstall script.Setting up Open Sound System....please waitDriver (osscore) not installed.add_drv -m Contributors of all backgrounds and levels of expertise come here to find solutions to their issues, and to help other users in the Splunk community with their own questions. Ticket tracking is now hosted in JIRA: https://tickets.puppetlabs.com Description package { source => '/bogus/path', ensure => 'latest', provider => 'sun' } with something like this the error message I see with Log In E-mail or User ID Password Keep me signed in Recover Password Create an Account Blogs Discussions CHOOSE A TOPIC Business Intelligence C Languages Cloud Computing Communications Technology CRM click for more info

Pkgadd Error Attempt To Process Datastream Failed - Bad Format In Datastream Table-of-contents

Blogs Recent Entries Best Entries Best Blogs Blog List Search Blogs Home Forums HCL Reviews Tutorials Articles Register Search Search Forums Advanced Search Search Tags Search LQ Wiki Search Tutorials/Articles Search Don’t forget that may packages require additional “dependencies” and they themselves have their own dependencies for example: Apache-2.4.4 Solaris 10 SPARC: • expat-2.0.1 • libiconv-1.14 • openldap-2.4.34 o libtool-2.4.2 • coreutils-8.21 If you have other questions, please feel free to submit them to our support email address. Not using -d has nothing to do with the package format, "man pkgadd" for details.

All product names are trademarks of their respective companies. You should try: sudo pkgadd -d /oss-solaris-v4.0-1016-i386.pkg type in the Super User password and then answer the questions. The ‘as' program can be found in the directory /usr/ccs/bin/ You will need to add this to your UNIX PATH. Aafaque Shaikh replied Jun 21, 2011 Hello techies....

You're now being signed in. Charles Wray replied Jun 20, 2011 You need to tell it that its in that directory pkgadd -d In this case, you need to do mv gcc-3.4.6-sol8-sparc-local gcc-3.4.6-sparc-local.gz gunzip gcc-3.4.6-sol8-sparc-local.gz pkgadd -d gcc-3.4.6-sol8-sparc-local (as root).

The /var/spool/pkg directory is usually the culprit for this sort of error message. Join our community today! We try to put package documentation in /usr/local/doc subdirectories for convenience. The software here consists of gzipped pkgadd files.

Pkgadd Error No Packages Were Found In Var Tmp

Yes. you could try here It is always a good idea to back up anything to plan to delete or move before you do it. Pkgadd Error Attempt To Process Datastream Failed - Bad Format In Datastream Table-of-contents I used the *NIX tool to install multiple versions (8,9 and 10) of Solaris simultaneously. Pkgadd No Packages Were Found In Var Spool Pkg Bug #2940 Package resource with ensure=>latest and invalid source gives "undefined method" error msg Added by Alan Harder over 6 years ago.

It means you can download up to 10 packages over the next 12 months. see here Romeo Ninov replied Jun 21, 2011 And also will be good to check with file command the type of the file(package) Top Best Answer 0 Mark this reply as the best SFWsudo.pkg Regards Sadiq Top Best Answer 0 Mark this reply as the best answer?(Choose carefully, this can't be changed) Yes | No Saving... It worked flawlessly (after chanignthe defulat installation folder from, Program Files (x86)/...; to simply, Program Files/...). Pkgadd Solaris

This package is on the Solaris 2.x CD. Note that registered members see fewer ads, and ContentLink is completely disabled once you log in. Main Menu LQ Calendar LQ Rules LQ Sitemap Site FAQ View New Posts View Latest Posts Zero Reply Threads LQ Wiki Most Wanted Jeremy's Blog Report LQ Bug Syndicate Latest this page and that is an important factor.

I use following steps to install ( please confirm if correct) 1> gunzip splunk-4.1.6-89596-solaris-8-sparc.pkg.Z The above gives me splunk-4.1.6-89596-solaris-8-sparc.pkg 2> pkgadd -d ./splunk-4.1.6-89596-solaris-8-sparc.pkg At this point it gives error :(. Mahtab Dalal replied Jun 20, 2011 Go where your pkg stored or run the command pkgadd -d SFWsudo /var/spool/pkg is default location for spooling or dumping the pakg's in solaris Top Thanks!

However, I am not familiar with the syntax required in order to add (execute) the files to the Solaris machines.

Some version (usually old) of gzip is available on many levels of Solaris or you can download one of our gzip packages for your system. It might say,

invalid compressed data -- crc error! Can do the following as root:

# cd /tmp (or where you put the program file) # gunzip program-1.00-sol8-sparc-local.gz # mkdir /tmp/spool (this can be any directory in a place with Please advise.

there is an SFWxmms package on CCD and I want to install it.But when cd into the directory containing the package and run "pkgadd -d SFWxmms" ,it complain: Code: bash-3.00# pkgadd I get, pkgadd: ERROR: attempt to process datastream failed - bad format in datastream table-of-content pkgadd: ERROR: could not process datastream from My gut tells me that the downloaded file regards Dev Mazumdar Top Crltn New Member Posts: 3 Joined: Thu Jun 26, 2008 4:27 am Location: The Great Land oss issue Quote Postby Crltn » Fri Jun 27, 2008 3:11 Get More Info Thanks.

http://support.bigfix.com/install/besclients-nonwindows.html#solaris mistervernon91 270004W3KC 18 Posts Re: Solaris package installation ‏2011-03-07T21:17:33Z This is the accepted answer. Asked: Dec 08, 2010 at 04:47 PM Seen: 2224 times Last updated: Dec 9, '10 Related Questions Can I auto-install or deploy Splunk onto all my remote Windows servers? 6 Answers Not what you were looking for? Updated about 6 years ago.

UNIX Packages is not an authorized Oracle re-seller, hence we can not supply past or present copies of the Solaris OS. These are the directory where you downloaded the package and gunzipped it, the /usr/local or /opt directory where the final installation is done,the /var/tmp or /var/spool/pkg directories where pkgadd puts intermediate I forget the details, but depending on the type of package, you have to treat them differently. For more advanced trainees it can be a desktop reference, and a collection of the base knowledge needed to proceed with system and network administration.

If you don’t use all your download tokens within the 12 months, you lose them. These aren't my boxes - but I suspect that there is an error in the build of the sol10 box at this point. Thanks. Error while running pkgadd Aafaque Shaikh asked Jun 20, 2011 | Replies (15) Dear Techies, I have downloaded the package for Sudo .

Re-FTP in binary format . By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. Show: 10 25 50 100 items per page Previous Next Feed for this topic Sign in Register Puppet Labs Site Documentation Support Contact Us Download Home Projects Help Search: Puppet Overview Crltn Top dev Developer Posts: 581 Joined: Fri Sep 12, 2003 6:08 am Location: Culver City, CA Contact: Contact dev Website Quote Postby dev » Thu Jun 26, 2008 9:59 pm

so this behavior isn’t great either. People... SFWsudo.pkg Top Best Answer 0 Mark this reply as the best answer?(Choose carefully, this can't be changed) Yes | No Saving... What I did was I changed the ownership of the file to root and then ran pkgadd -d . command and it worked.

Alastair France replied Jun 20, 2011 Typically YOU don't move the package to the /var/spool/pkg directory - pkgadd does what it needs to do itself. Status:ClosedStart date:12/16/2009Priority:NormalDue date:Assignee:Alan Harder% Done:0%Category:packageTarget version:0.25.2 Affected Puppet version:0.25.2rc1 Branch:http://github.com/MarkusQ/puppet/tree/ticket/0.25.x/2940 Keywords: We've Moved!