Home > Perl Error > Perl Error When Reading Localsite

Perl Error When Reading Localsite

Try this; from the command line, $ cd lib $ perl LocalSite.cfg If perl barfs, you should be able to see what the problem is. -- CrawfordCurrie - 13 Jul 2007 While these are provided in the hope that they will be useful, please note that we cannot vouch for the accuracy or timeliness of externally hosted materials. good solution really - I'm going to remove that line (from the 1.1.7 package onwards) an allow configure to set it -- SvenDowideit - 11 Feb 2013 Known Uses Known Limitations Visit http://example.com/TWiki/TWikiRegistration” to register new users to be able to edit the wiki. have a peek at these guys

Check the configuration settings for {TemplateDir} and {TemplatePath}. Here, my guess is that, as you've protected it with Apache, Apache will see the protection, and issue a 401 to the browser. SupportCategory CategoryInstallation TWiki version 4.2.4 Server OS MS Windows Server 2003 Web server IIS 6 Perl version 5.10.0 Edit|Attach|Watch|Print version|History: r3here

Tasks Log In Register Quick Links Extensions and Components Waiting For Feedback Website Tasks Project Tasks Tools Create New Topic Index Search Changes Notifications RSS Feed Statistics Preferences The copyright of See Copyright Statement. Čeština Dansk Deutsch Ελληνικά English Español Suomi Français Italiano 日本語 Nederlands Norsk Polski Português Português brasileiro Русский Svenska tlhIngan Hol Українська 简体中文 正體中文 About Blog Extensions When I go to http://localhost/foswiki/bin/configure , I get "perl error reading LocalSite.cfg" (see below). But I'll try if there's any suggestions.

Send feedback. Tags: tag this topic create new tag, view all tags SID-00203: Where is LocalSite.cfg ? See Copyright Statement. The status selector is below the edit box.

Thanks. -- LucGarcia - 19 Mar 2009 Change status to: Asked question Answered question Closed unanswered If you answer a question - or someone answered one of your at /var/foswiki/bin/view line 43 For help, please send mail to the webmaster (webmaster@foswiki), giving this error message and the time and date of the error. at /var/lib/foswiki/lib/Foswiki.pm line 615 require Foswiki.pm called at /var/lib/foswiki/bin/view line 22 main::BEGIN() called at /var/lib/foswiki/lib/Foswiki.pm line 615 eval {...} called at /var/lib/foswiki/lib/Foswiki.pm line 615 Compilation failed in require at /var/lib/foswiki/bin/view line http://www.twiki.org/cgi-bin/view/Support/SID-01063 However when 142 =configure= runs it has to get default values for config vars that have not 143 yet been saved to =LocalSite.cfg=. 144 145 Returns a reference to a list

at /var/lib/foswiki/bin/view line 22 Context I am running Postfix, and seeing how this line invokes some kind of mail function (I'm not familiar with perl) it may be a problem with The alternative of securing by restricting to certain IP addresses works, except that the configure page gives a warning encouraging the user to use a setting that makes the configure page at a stage where LocalSite.cfg is not supposed to exist, since that's the 1st time configure is ran. -- RaulFRodriguez - 15 Jul 2009 As for 1. This is a high security risk!

I'm more curious as to why this happened than anything. look at this web-site This guide outlines a basic TWiki installation, setup, and configuration process. Consider the following configuration directives: /etc/apache2/conf.d/twiki.conf 1 2 3 4 5 6 SetHandler cgi-script Order Deny,Allow Deny from all Allow from 127.0.0.1 Add your local IP address to the Structured wikis provide a powerful way to share, store, and work with information in task centric applications.

i.e., I applied the following patch to the Load.pm from a Foswiki 1.0.9: http://trac.foswiki.org/changeset/6313 After applying the patch, the access to configure as described in this error report, without an existing More about the author I know I should do some changes to that file from some cookbooks but I cannot find the file to do it. See also Support.Faq19 -- PaulHarvey - 22 Feb 2010 I think I fixed this in the recent ApacheConfigGenerator. See Copyright Statement. Čeština Dansk Deutsch Ελληνικά English Español Suomi Français Italiano 日本語 Nederlands Norsk Polski Português Português brasileiro Русский Svenska tlhIngan Hol Українська 简体中文 正體中文 About Blog Extensions

What am I doing wrong? I've improved the reporting, and I'll close this bug. -- OlivierRaginel - 28 Jul 2009 I just applied the patch to Load.pm against a fresh copy of 1.0.6, which cures "error TWiki is a robust “structured wiki” roughly comparable to other “Enterprise” wiki solutions such as Confluence. check my blog Search guides and tutorials In This Guide: Prepare System and Install TWiki Install Prerequisites Install TWiki Configure Software Configure Apache Web Server Configure TWiki Install TWiki More Information RSS feed Monthly

Here are what my permissions look like: drwxr-xr-x 5 apache apache 4096 Jul 8 18:09 lib in lib: -rw-r--r-- 1 apache apache 65143 Jul 8 15:42 LocalSite.cfg -- JimChan - 09 TWiki.spec is still read because so much of the core code doesn't 54 provide defaults, and it would be silly to have them in two places anyway. 55 56 =cut 57 Issue the following commands to create the required directories: 1 2mkdir -p /srv/www/example.com/public_html mkdir -p /srv/www/example.com/logs Configure TWiki Edit the $twikiLibPath value in the /srv/www/example.com/twiki/bin/LocalLib.cfg file to reflect the location of

It looks like the reason why the affected system was generating this error is not there anymore, and that it is not (entirely) due to Olivier's patch in case of a

Thanks in advance. == Software error: Content-type: text/plain Perl error when reading LocalSite.cfg: Please inform the site admin. Solution I simply commented out line 82 or LocalSite.cfg with a '#' and it compiled fine after that. Environment: SuSE 10.2 Perl 5.8.8 Apache 2.2.3 -- PaulHarvey - 03 Aug 2009 Altered title to the fix that was actually applied. -- KennethLavrsen - 05 Aug 2009 The applied fix Tags: tag this topic create new tag, view all tags Question I have tried everything I could in the support questions/forums/google, but for whatever reason, my Twiki 4.1.2 instance won't run.

See Copyright Statement. Čeština Dansk Deutsch Ελληνικά English Español Suomi Français Italiano 日本語 Nederlands Norsk Polski Português Português brasileiro Русский Svenska tlhIngan Hol Українська 简体中文 正體中文 About Blog Extensions Modify the following lines if you wish to deploy TWiki at a different location on your domain. /etc/apache2/conf.d/twiki.conf 1 2 3 4ScriptAlias /wiki/bin "/srv/www/example.com/twiki/bin" Alias /wiki/pub "/srv/www/example.com/twiki/pub" Alias /wiki/ "/srv/www/example.com/twiki/bin/view/" I am not sure the testing will be fully accurate, since the installation process is quite different when installing from an SVN checkout of trunk, compared to a regular installation from news Also, set up apache config file .

Because of this flexibility, TWiki straddles the boundary between web application and web application framework.